Parent Square failing DMARC check via Mimecast

Incident Report for CNYRIC Status Page

Resolved

The Parent Square team has troubleshot the issue and has identified the cause. They had to get with their email service provider and correct some of the configuration/s to fix the issue. Currently no longer getting any failure reports. Please be advised that you should not experience this issue going forward!
Posted Mar 27, 2025 - 14:44 EDT

Identified

CNYRIC E-Comms group has been in contact with Parent Square. Parent Square believes it is their issue. They are currently working to solve the issue, hoping to have it corrected soon. Thank-you.
Posted Mar 27, 2025 - 11:02 EDT
This incident affected: Ancillary (CNYRIC OTHER).