Citrix / Financial application issues.

Incident Report for CNYRIC Status Page

Resolved

The issues with the financial application's has been resolved, though, if you still are having issues, please contact your CNYRIC financial rep. Thank-you
Posted Jan 06, 2026 - 10:38 EST

Investigating

Currently the CNYRIC is receiving multiple reports of issues with the Citrix / Financial application. Users are receiving errors and are unable to access the application. Tech support is currently investigating will follow up as updates come in.
Posted Jan 06, 2026 - 10:01 EST
This incident affected: Financial Services (Nvision, Wincap, School ERP Pro, Citrix).