Diligent Customer Facing Incident - BoardDocs - Users are unable to access the application - 1 May 2026

Incident Report for CNYRIC Status Page

Update

The Vendor is continuing to investigate the issue.
Posted May 01, 2026 - 13:28 EDT

Investigating

From the Vendor:


BoardDocs - Users are unable to access the application
New incident: Investigating
We are currently investigating this issue.
Time posted
May 1, 15:30 UTC
Components affected
Degraded Performance Boards & Governance – BoardDocs - Boa...
Posted May 01, 2026 - 11:39 EDT
This incident affects: Ancillary (CNYRIC OTHER).