Cloudflare Issues

Incident Report for CNYRIC Status Page

Resolved

The CNYRIC continues to see pre incident functionality on all Cloudflare services utilized by the CNYRIC. At this time, we will be closing this incident. For updates on Cloudflare, you can go the this link: www.cloudflarestatus.com
Posted Nov 18, 2025 - 12:06 EST

Update

Cloudflare has implemented a fix and continues to focus on restoring service post-fix. Cloudflare is mitigating several issues that remain post-deployment. The CNYRIC has seen pre incident functionality on all Cloudflare services utilized by the CNYRIC. The CNYRIC will continue to monitor Cloudflare for updates.
Posted Nov 18, 2025 - 10:50 EST

Monitoring

The CNYRIC has seen an improvement in services for our applications. We will continue to monitor.
Posted Nov 18, 2025 - 09:40 EST

Update

Cloudflare Status page states: Update - We are continuing working on restoring service for application services customers. The CNYRIC has not seen any improvement in Cloudflare services and will continue to monitor.
Posted Nov 18, 2025 - 09:06 EST

Identified

The CNYRIC has also confirmed that Cloudflare's Web Application Firewall(WAF) services are also affected by the outage. This is affecting third parties websites that are utilizing those services. The CNYRIC.org website is affected and users are receiving a Cloudflare error while navigating to this website.
Posted Nov 18, 2025 - 08:20 EST

Investigating

CNYRIC is aware of a Cloudflare Global issue affecting CNYRIC hosted DNS. Status for Cloudflare is as follows:

Cloudflare is aware of, and investigating an issue which impacts multiple customers: Widespread 500 errors, Cloudflare Dashboard and API also failing. We are working to understand the full imp[act and mitigate this problem. More updates to follow.

CNYRIC will continue to investigate the impacts to our organization.
Posted Nov 18, 2025 - 07:47 EST
This incident affected: Ancillary (CNYRIC OTHER).