All Financial & Citrix systems are operational. The CNYRIC will be closing this incident, and will provide a postmortem on the root cause.
Posted Aug 19, 2026 - 14:30 EDT
Monitoring
Citrix Engineers were able to identify the root cause that resulted in the black screen issues. The CNYRIC has applied the fix and all financial services have been restored. The CNYRIC will continue to monitor.
Posted Aug 19, 2026 - 13:26 EDT
Update
Technology team is continuing to resolve the issue. Still no ETA . Will update as more information is available.
Posted Aug 19, 2026 - 11:22 EDT
Update
The CNYRIC is currently working with Citrix support team , no ETA at this time.
Posted Aug 19, 2026 - 08:47 EDT
Update
We are continuing to investigate this issue.
Posted Aug 19, 2026 - 08:00 EDT
Investigating
We are currently investigating the partial outage effecting Citrix this morning. Users are experiencing a black screen rather than the normal login prompt when trying to access. Will update as more information becomes available.
Posted Aug 19, 2026 - 07:49 EDT
This incident affected: Financial Services (Nvision, Wincap, Citrix).