CNYRIC Power Surge

Incident Report for CNYRIC Status Page

Resolved

This incident has been resolved as CNYRIC has completed its checks. If you are experiencing any issues with hosted services, please contact the CNYRIC helpdesk.
Posted Jul 22, 2026 - 10:16 EDT

Monitoring

The CNYRIC experienced a power surge which resulted in unexpected reboot of storage infrastructure. All monitoring systems show system have returned to normal operation. However the CNYRIC is working to review all hosted services to confirm operation.
Posted Jul 22, 2026 - 06:52 EDT
This incident affected: Ancillary (CNYRIC OTHER).