CNYRIC Citrix Outage

Incident Report for CNYRIC Status Page

Resolved

The CNYRIC Citrix environment has been restored.
Posted Jan 07, 2026 - 16:08 EST

Investigating

The CNYRIC Citrix environment is currently down. Technicians are working to identify the issue. This is affecting logins for all CNYRIC Citrix applications
Posted Jan 07, 2026 - 15:57 EST
This incident affected: Ancillary (CNYRIC OTHER) and Financial Services (Citrix).