Wincap Web Down

Incident Report for CNYRIC Status Page

Resolved

Good Morning,

WinCapWEB is now back online.

Thank you
Posted Jul 30, 2026 - 07:48 EDT

Investigating

Good Morning,

WinCapWEB is currently down. We will update everyone as soon as we have more information.

Thank you
Posted Jul 30, 2026 - 07:15 EDT
This incident affected: Financial Services (Wincap).