BoardDocs Connectivity Issues – Ongoing Performance Problems

Incident Report for CNYRIC Status Page

Resolved

BoardDocs - Sites Are Inaccessible In The US Region
Incident resolved
This incident has been resolved.
Time posted
Apr 28, 22:08 UTC
Components affected
Operational Boards & Governance – BoardDocs - Boa...
Posted Apr 29, 2026 - 08:23 EDT

Update

We are continuing to monitor for any further issues.
Posted Apr 29, 2026 - 06:59 EDT

Monitoring

From the Vendor:

BoardDocs - Sites Are Inaccessible In The US Region
Incident status: Monitoring
A fix has been implemented and we are monitoring the results.
Time posted
Apr 28, 18:30 UTC
Components affected
Major Outage Boards & Governance – BoardDocs - Boa...
Posted Apr 28, 2026 - 14:38 EDT

Update

From the Vendor:

We are aware of a current system issue currently affecting BoardDocs sites in the US region. Our support and engineering teams are working on a resolution but a confirmed timeline is not yet available. We apologize for the disruption and inconvenience. Please continue to monitor https://status.diligent.com/ for updates and information.
Posted Apr 28, 2026 - 10:11 EDT

Investigating

From the Vendor:

BoardDocs - Sites Are Inaccessible In The US Region
Incident status: Investigating
We are currently investigating this issue.
Time posted
Apr 28, 13:03 UTC
Posted Apr 28, 2026 - 09:22 EDT
This incident affected: Ancillary (CNYRIC OTHER).