Summary: We have mitigated an issue where some customers experienced login issues to Google services.
Description: Between 07:22 and 08:30 PDT, customers experienced login issues to Google services.
Our engineering team has identified the cause and applied appropriate mitigations by 08:30 PDT. Customers should now be able to login to the Google services.
We are closely monitoring the environment for stability.
We will provide an update by Thursday, 2025-09-18 09:20 PDT with current details.
We apologize to all who are affected by the disruption.
Symptoms: Some customers experienced login issues to Google services.
Workaround: None at this time.
Posted Sep 18, 2025 - 13:22 EDT
Identified
Have confirmation from status page that are experiencing a global issue and that Google Engineers are currently work to correct. Please refer to the following like google.com/appstatus/dashboard
Posted Sep 18, 2025 - 12:10 EDT
Investigating
We are receiving reports of Google 502 errors through out the region. No official word as of yet, We will continue to investigate and update as more data is available.
Posted Sep 18, 2025 - 11:16 EDT
This incident affected: Cloud Services (Google Apps Google Docs, Google Apps Google Drive, Google Apps Gmail).