The issue has been identified and a fix is being implemented.
Posted Jul 15, 2025 - 14:48 EDT
Update
The Vendor is continuing to work on the issue. We have not been notified of an ETR. More information will be posted as it becomes available.
Posted Jul 15, 2025 - 13:30 EDT
Update
The Vendor is continuing to work on the issue. We have not been notified of an ETR. More information will be posted as it becomes available.
Posted Jul 15, 2025 - 11:08 EDT
Update
The Vendor is continuing to work on the issue. We have not been notified of an ETR. More information will be posted as it becomes available.
Posted Jul 15, 2025 - 09:31 EDT
Update
As of this morning, the Vendor is still looking into what the issue is and what is causing it. There is no ETR as of yet. We will post more information as it becomes available.
Posted Jul 15, 2025 - 08:01 EDT
Update
Still working with the Vendor to find a resolution to the issue.
Posted Jul 14, 2025 - 14:20 EDT
Update
Still working with the Vendor to find a resolution to the issue.
Posted Jul 14, 2025 - 13:15 EDT
Update
We are still working with the Vendor to investigate the issue.
Posted Jul 14, 2025 - 12:16 EDT
Update
We are continuing to work with the Vendor to investigate this issue.
Posted Jul 14, 2025 - 10:58 EDT
Investigating
We are investigating intermittent connection errors affecting some Citrix users. Our team is actively working with Citrix to resolve the issue.