Microsoft 365 - Degraded service functionality

Incident Report for CNYRIC Status Page

Resolved

Recent check of the Microsoft Status page is showing normal status for 365
https://status.cloud.microsoft/m365/referrer=serviceStatusRedirect
Posted Jan 23, 2026 - 07:41 EST

Update

According to Microsoft's statuspage https://status.cloud.microsoft/m365/referrer=serviceStatusRedirect
They are still having issue with 365
Posted Jan 22, 2026 - 19:24 EST

Update

Posted Jan 22, 2026 - 15:33 EST

Monitoring

Microsoft 365 (Business or Enterprise) https://status.cloud.microsoft/m365/referrer=serviceStatusRedirect
Users may be seeing degraded service functionality or be unable to access multiple Microsoft 365 services
Posted Jan 22, 2026 - 15:31 EST
This incident affected: Ancillary (CNYRIC OTHER).