BoardDocs: Service Interruption today, 4/27/26

Incident Report for CNYRIC Status Page

Resolved

This incident has been resolved.
Posted Apr 28, 2026 - 08:09 EDT

Investigating

Our Support and Engineering teams are working on a resolution but a confirmed timeline is not yet available.

We apologize for the disruption and inconvenience.

Please continue to monitor https://status.diligent.com/ for updates and information.

Thank you,
Posted Apr 27, 2026 - 13:27 EDT
This incident affected: Ancillary (CNYRIC OTHER).