Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted Mar 18, 2025 - 00:00 EDT
Update
We will be undergoing scheduled maintenance during this time.
Posted Mar 10, 2025 - 08:02 EDT
Scheduled
Please be advised that it will be necessary for Northland Communications to perform service-affecting maintenance to our voice and internet services network during the following date and time:
Tuesday, March 18, 12:01 am - 6:00 am
During this window, you may experience brief interruptions in Voice, Internet, and MPLS services. We anticipate these interruptions to be minimal, and we kindly request your understanding as we diligently work to prevent disruptions. We apologize for any inconvenience and sincerely appreciate your cooperation. Your support ensures the optimal performance of our network facilities and equipment.
If you have any questions about this upcoming maintenance or need to update your contact information, please contact us at noc@northland.net or 866-624-2033.
Posted Mar 04, 2025 - 15:17 EST
This scheduled maintenance affected: Voice Services (Northland Communication).