BoardDocs Website latency

Incident Report for CNYRIC Status Page

Resolved

BoardDocs is running as it should be. Thank-you for you patience.
Posted Sep 08, 2025 - 18:51 EDT

Investigating

Users are experiencing latency when attempting to use BoardDocs website. Vendor Diligent is still in the investigation phase. Will update as information is provided.
Posted Sep 08, 2025 - 14:52 EDT
This incident affected: Ancillary (CNYRIC OTHER).